Scenario audit only one page

i am trying to run 5 different scenario audit that all starts from the same page.
The first time i just recorded ad executed on asqatasun. But after the 5 audit i saw the scan was only one page so all the 5 scenario has the same result.
So i rerun the script locally and discovered that selenium failed also.
Now i replaced some the recorded steps (mainly text identification) with xpath or css selector (as suggested in another conversation). Now locally i can rerun the json without any issue multiple times but in asqatasun i have always just one page analyzed.
Is there a way to check which steps fails in asqatasun?

Here 3 version of the json for the same scenario second and third version both run correctly in local firefox+selenium builder.

WTS_MyReq_FollowUp.json (1.2 KB) WTS_MyReq_FollowUp2.json (1 KB) WTS_MyReq_FollowUp3.json (1.0 KB)



Hi again,
i wasn’t able to progress with this issue.
The idea was to enable firefox open a window during the run in order to understand what happened,
i tried to follow the instructions here but i cannot run xhost + . I don’t know the reason. I am running on Ubuntu server 18.04 configured with the installation script of asqatasun.
I am connected remotely via ssh to the server so maybe this is the problem.
I stopped the service xvfb@:99 but when i try to run xhost + i have xhost: unable to open display “”
Anyone have any idea how I can do that?

Thank you very much in advance.