Remarks and Issues

Hello everyone,

Today I’m coming with many questions and remarks ^^
I don’t know if it’s more accurate to put all in one topic or to separate them so I’m sorry if I’m putting everything in here.

1 - I’ve noticed that I don’t have the Manual audits for all my projects as we can see bellow, I tried to edit the project and adding the Manual audit and also to create a new one,… in vain.


2 - I had a problem with my VM last week, (Asqatasun couldn’t perform tests anymore) so I’ve reboot it, I’ve also reboot the api and webapp services but I’m still having the hourglass like if there is some audit running, although I don’t have anything running from the logs,
PS : It’s not blocking my work, I can run my tests like I want it’s just a little bit disturbing if you see what I mean :grin:

3 - This is more important and blocking. I’m running a scenario with a Drag&Drop command, and a popup shows up right after. In Selenium IDE the scenario works fine, but Asqatasun is blocked at the step right after the Drag&Drop. I tried to change the target in Selenium by putting the CSS:finder, xpath or id but everytime Asqatasun stops at this step because he can’t find the popup I’m guessing.
I’d like to know if it’s something related to Asqatasun or to the website I’m targeting.

Thank you so much for you help :blush:

Hello @oanass

I’ll try to give an answer to each of your points :slight_smile:

Point 1 Manual scenario

If I remember correctly, we disabled the manual scenarios as they we buggy. @fabrice @koj am I right?

Point 2 hourglass still present

You have this because (at least) one audit was still running when you reboot your VM, or it is stuck for another reason (see logs).

As you identified, this is not blocking

Point 3 scenario with drag’n’drop

It is hard to answer without the audited application. But you can build your own Asqatasun, and extend the log level, or even display the Firefox managed by Asqatasun, which may lead you to a clearer understanding of what’s going on.

See doc in Debugging Asqatasun and maybe Development environment to build locally.

Hope this helps!

1 Like

Hello again,

I was working on the build of my own Asqatasun in order to add logs like you suggested.
My api is running so does my webapp, but I had the issue of css as you can see bellow:

I tried to delete the target directory and the .m2/ as mentioned on the note, but it doesn’t work cause it seems like they are auto generated each time.

In the note it’s written : “if you happen to build from within IntelliJ and also from the command-line”, I’m a little bit confused cause am actually trying to run it just via IntelliJ. Maybe I’m doing something wrong if you can help me through it.

This will help me debug the other issue with one page tested.

Thank you :blush:

Thank you again for your detailed report @oanass!

I reproduce. So it seems to be a local build issue. I tried locally (on my workstation) to rebuild Asqatasun at tag v5.0.0-rc.1, and I’ve got the same issue : CSS are not loaded. Whereas build by the CI, it is OK.

So this is merely a documentation issue on how to build :slight_smile:

I’m investigating…

So, documentation have been updated. For developers, you now have:

Hope this helps!

Hi @oanass

The doc on how to build (and run) Asqatasun with IntelliJ has been fixed. I would love to hear your feedback :slight_smile:

(And by the way, the underlying bug has also been described, with possible fixes.)

1 Like

Hello @mfaure

Thank you so much, I confirm that the documentation is now up to date and allow us to build a proper Asqatasun.

Many thanks!

1 Like