Not getting an audit

firefox-esr
firefox
installation
Tags: #<Tag:0x00007f2ce20fd320> #<Tag:0x00007f2ce20fd140> #<Tag:0x00007f2ce20fcfb0>

#4

And from the log files i found an error example, hope that helps:

java.lang.RuntimeException: Test run failed: unable to create driver.
    at org.asqatasun.scenarioloader.ScenarioLoaderImpl.run(ScenarioLoaderImpl.java:217)
...
more similar
...
Caused by: org.openqa.selenium.WebDriverException: Failed to connect to binary FirefoxBinary(/opt/firefox-31.4.0esr/firefox) on port 7055; process output follows: 
(process:6520): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: cannot open display: 99
 
(process:6527): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: cannot open display: 99

Maybe the fault is <path_to_Firefox_ESR_binary>
in the installation script?? I see that i used this path : /opt/firefox-31.4.0esr/firefox
and the example has /opt/firefox/firefox this path…


#5

use smtp options into asqatasun.conf :

  • smtp.host
  • smtp.user
  • smtp.password
# Email sender configuration
# Uncomment the following lines and the corresponding lines in tgol-web-app/src/main/webapp/WEB-INF/conf/tgol-beans-email-sender.xml
# if you need a specific smtp server configuration (defaults uses postfix on localhost)
# SMTP host to connect to to send mails
#smtp.host=localhost
# "From: mail addresse to use
#smtp.from=r2d2@asqatasun.org
# Login and Password to connect to the SMTP server
#smtp.user=
#smtp.password=

#6

I see that i used this path : /opt/firefox-31.4.0esr/firefox
and the example has /opt/firefox/firefox this path…

Where do you see this example (URL, page) ?


/opt/firefox-31.4.0esr/ directory
and /opt/firefox-31.4.0esr/firefox file exist on your OS?

you can look at a similary topic:


#7

I mean the example installation in the Asqatasun-en.pdf on page 54. Yes they exist but also /opt/firefox/firefox exists…so maybe i had to put this instead…


#8


#9

I had not chosen the Audit Files option, should I? Maybe the older version of firefox didn’t replace the by default installed firefox on Ubuntu 14.04…


#10

can you do this :
ls -l /opt/ | grep firefox


#11

They are both installed as i can see…

lrwxrwxrwx 1 root root   17 Οκτ   2 21:02 firefox -> firefox-31.4.0esr
drwxr-xr-x 8 root root 4096 Ιαν   6  2015 firefox-31.4.0esr

#12

yes, I think it’s works !


#13

Still getting the same result…


#14

what do you see in logs files after this file audit ?


if you want, you can test quickly Asqatasun with Docker :

docker pull asqatasun/asqatasun  
docker run --name asqatasun -d -p 8082:8080  asqatasun/asqatasun

http://localhost:8085/asqatasun/


#15

Error response from daemon: driver failed programming external connectivity on endpoint asqatasun (b8a60196a260909c76e007be933a555bcaf8152842678c4e493f86e695268584): Error starting userland proxy: listen tcp 0.0.0.0:8080: bind: address already in use
Error: failed to start containers: asqatasun


#16

I think it has not been yet in logs (probably not crashed yet)
but i assume it will be the same as before


#17

for using Docker, you must shutdown tomcat (port 8080)
or use another port like this :

 docker run --name asqatasun -d -p 8082:8080  asqatasun/asqatasun
http://localhost:8082/asqatasun/

#18

Same here…I will try to uninstall the newer edition of firefox


#19

Unfortunately not resolved even with the right version of Firefox…


#20

Also, i noticed that in /opt/firefox-31.4.0esr there are firefox and firefox-bin…Which is the right to point to? And how can i change this?


#21

it’s normal. These are executable files of Firefox ESR 31

for example, in a docker container of Asqatsun, we have:

and the --firefox-esr-binary-path
parameter used with the installation script is:

install.sh (…) --firefox-esr-binary-path /opt/firefox/firefox

the same command line we can use
that does not use the symbolic link /opt/firefox

install.sh (…) --firefox-esr-binary-path /opt/firefox-31.4.0esr/firefox

in this example :
/opt/firefox/firefox (symbolic link) = /opt/firefox-31.4.0esr/firefox

Problem and solution

I think your problem and the solution are described here :

Can you tell us what is the result of the following command lines ?

ps axf | grep -i xvfb
cat /etc/default/tomcat7

#22

ok thanks a lot problem solved with reinstall.


#23

Great! :+1: :dizzy: