Not getting an audit

Tags: #<Tag:0x00007f2ce2335340> #<Tag:0x00007f2ce23351b0> #<Tag:0x00007f2ce2334f58>


Hi! I’m a new user of asqatasun and i haven’t yet gotten an audit although i try. Everytime i get the following message: It will take more time to analyse this HTML (that would deserve more
love). Don’t worry, the result will appear in a while in the audit
history. In addition, we’ll send you an email to let you know when it’s all done.
Unfortunately i get no result neither an email. How long sould i wait? I have tried for a single page, for multiple pages, for a whole site and for a scenario with the same result…


Hi @nivak91,

Can you give us a little more information?

  • it is you who made the Asqatasun installation?
  • using the docker version ?
  • Have you access to log files? /var/log/asqatasun/asqatasun.log and /var/log/tomcat7/catalina.out
  • Which version of Asqatasun ? (visible in the footer)
  • Network environment : proxy ? …

send you an email to let you know when it’s all done.

Only if it’s configured in the asqatasun.conf file.

How long sould i wait?

  • Page audit : between 5 seconds and a few minutes
  • Site audit : between a few minutes (10 to 20 pages) and a few hours (+ 1000 pages)

  • Have you tested the file audits?
  • Have you tested the file audits?


Ok, i made the installation accordind to the asqatasun-en.pdf without using docker and i have access to the log files. The version is Asqatasun v4.0.3 and i am connected to the internet if that is what you mean. Where is the file audits? Should i change the asqatasun.conf file like this: emailSentToUserExclusionList=‘’ ?


And from the log files i found an error example, hope that helps:

java.lang.RuntimeException: Test run failed: unable to create driver.
more similar
Caused by: org.openqa.selenium.WebDriverException: Failed to connect to binary FirefoxBinary(/opt/firefox-31.4.0esr/firefox) on port 7055; process output follows: 
(process:6520): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: cannot open display: 99
(process:6527): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: cannot open display: 99

Maybe the fault is <path_to_Firefox_ESR_binary>
in the installation script?? I see that i used this path : /opt/firefox-31.4.0esr/firefox
and the example has /opt/firefox/firefox this path…


use smtp options into asqatasun.conf :

  • smtp.user
  • smtp.password
# Email sender configuration
# Uncomment the following lines and the corresponding lines in tgol-web-app/src/main/webapp/WEB-INF/conf/tgol-beans-email-sender.xml
# if you need a specific smtp server configuration (defaults uses postfix on localhost)
# SMTP host to connect to to send mails
# "From: mail addresse to use
# Login and Password to connect to the SMTP server


I see that i used this path : /opt/firefox-31.4.0esr/firefox
and the example has /opt/firefox/firefox this path…

Where do you see this example (URL, page) ?

/opt/firefox-31.4.0esr/ directory
and /opt/firefox-31.4.0esr/firefox file exist on your OS?

you can look at a similary topic:


I mean the example installation in the Asqatasun-en.pdf on page 54. Yes they exist but also /opt/firefox/firefox exists…so maybe i had to put this instead…



I had not chosen the Audit Files option, should I? Maybe the older version of firefox didn’t replace the by default installed firefox on Ubuntu 14.04…


can you do this :
ls -l /opt/ | grep firefox


They are both installed as i can see…

lrwxrwxrwx 1 root root   17 Οκτ   2 21:02 firefox -> firefox-31.4.0esr
drwxr-xr-x 8 root root 4096 Ιαν   6  2015 firefox-31.4.0esr


yes, I think it’s works !


Still getting the same result…


what do you see in logs files after this file audit ?

if you want, you can test quickly Asqatasun with Docker :

docker pull asqatasun/asqatasun  
docker run --name asqatasun -d -p 8082:8080  asqatasun/asqatasun



Error response from daemon: driver failed programming external connectivity on endpoint asqatasun (b8a60196a260909c76e007be933a555bcaf8152842678c4e493f86e695268584): Error starting userland proxy: listen tcp bind: address already in use
Error: failed to start containers: asqatasun


I think it has not been yet in logs (probably not crashed yet)
but i assume it will be the same as before


for using Docker, you must shutdown tomcat (port 8080)
or use another port like this :

 docker run --name asqatasun -d -p 8082:8080  asqatasun/asqatasun


Same here…I will try to uninstall the newer edition of firefox


Unfortunately not resolved even with the right version of Firefox…


Also, i noticed that in /opt/firefox-31.4.0esr there are firefox and firefox-bin…Which is the right to point to? And how can i change this?